<!DOCTYPE html>
<html class='controller-contents'>
<head>
<script type="text/javascript">window.NREUM||(NREUM={});NREUM.info={"beacon":"bam.nr-data.net","errorBeacon":"bam.nr-data.net","licenseKey":"def25c5cff","applicationID":"21817424","transactionName":"cwtcFxRXXF4ERBhSWV4QVw0SF1NdD0JSX0JDS0ELCU8=","queueTime":0,"applicationTime":367,"agent":""}</script>
<script type="text/javascript">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</script>
<script>
  var googleAnalyticsId = "UA-81891349-1";
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
  
  ga('create', googleAnalyticsId, 'auto');
</script>

<link href='https://fonts.googleapis.com/css?family=Roboto:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://fonts.googleapis.com/css?family=Roboto+Condensed:400,500,700|Merriweather:400,700,italic' rel='stylesheet'>
<link href='https://cdnjs.cloudflare.com/ajax/libs/selectize.js/0.8.5/css/selectize.default.css' rel='stylesheet'>
<title>UCFSports.com  -  Kyle Gibson embraces new staff</title>
<meta content='UCFSports.com  -  Kyle Gibson embraces new staff' property='og:title'>
<link rel="stylesheet" media="all" href="https://cdn.rivals.com/production/assets/application-2eada6c4ef76b32c1d573f4c7ad6fd2ed16b2c21706319015a98c50ca76b4e2e.css" />

<script src="https://cdn.rivals.com/production/assets/application-b0b83d6a3a0cc15b0251203e7d430d0d1d138232889f4a35aea2b9900ab5abc6.js"></script>
<meta name="csrf-param" content="authenticity_token" />
<meta name="csrf-token" content="QHXsJ0Vg2PqXPPyu/NImFABzpVXdLE0R9dztJK7HRKhEg33RDPHmfJFYjyeVKg8Ale9ydQz98xqnWG3EaG72GA==" />
<script type="application/javascript">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</script>

<meta content='initial-scale=1.0, width=device-width, maximum-scale=1.0' name='viewport'>
<meta content='https://cdn.rivals.com/production/assets/favicons/browserconfig-273d00a84d0505fdc2d9beb1315850199c1ab215394a98be1a63372ca20207de.xml' name='msapplication-config'>
<meta content='#0a4ea3' name='msapplication-TileColor'>
<meta content='https://cdn.rivals.com/production/assets/favicons/mstile-144x144-bbea1de48acc36b36c4ecbc46ec3289e31950d22f6370c08529de09bfece57b8.png' name='msapplication-TileImage'>
<meta content='#ffffff' name='theme-color'>
<meta content='https://ucf.rivals.com/news/kyle-gibson-embraces-new-staff' property='og:url'>
<meta content='https://cdn.rivals.com/image/upload/f_auto,q_auto,t_thumbnail/wd0tm5v6z1axsdaqdrbo' property='og:image'>
<meta content='Breaking up can be hard, but change is always a constant in college football.' property='og:description'>
<meta content='article' property='og:type'>
<meta content='2018-03-30 12:29:25 -0500' property='article:published_time'>
<meta content='2018-03-30 12:29:26 -0500' property='article:modified_time'>
<meta content='Article' property='article:section'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-57x57-7404e8851b384e973afdb1115390a36947dbf5fe28a232d84e5c6908cd7705d5.png' rel='apple-touch-icon' sizes='57x57'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-60x60-6648de94c2c3e41f6513ac5c0467ffd19f7c02e65a0fc936f1a9982f3ed748c8.png' rel='apple-touch-icon' sizes='60x60'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-72x72-8f5bdbc6adbf0c5fba8e0fcac9577fd4d33e68420787ee56f609e500a58b921f.png' rel='apple-touch-icon' sizes='72x72'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-76x76-6fe5688966b66892f842e9c4a9024cbca3c4cb1924d64c8d62a0ddbf47fc68e9.png' rel='apple-touch-icon' sizes='76x76'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-114x114-0372b897e5d8e989c1aeb7b4c620e3a3d1d7ce7406faf9ba0bfa6848c33b920a.png' rel='apple-touch-icon' sizes='114x114'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-120x120-783a1158ba513dae40547a7466182cab45cdd11c5d875c25c4c47b5da51c027e.png' rel='apple-touch-icon' sizes='120x120'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-144x144-8241e0d11a6d3b792f7ff1728e23e8d3d4c06a582e090d29c3dd0e3c075a9105.png' rel='apple-touch-icon' sizes='144x144'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-152x152-7882a3d3bb9b9b3b702c4e642b2c161e2efc0e47150051764e987199e58bd8c0.png' rel='apple-touch-icon' sizes='152x152'>
<link href='https://cdn.rivals.com/production/assets/favicons/apple-touch-icon-180x180-07196b8cded86c2a4bf5c14f585d72da8fb6c20c3246efc59fa27678059c9940.png' rel='apple-touch-icon' sizes='180x180'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-16x16-8f32636231ae820b22a672b74aedfff6c3106cccaeb865a002330d943f6910f4.png' rel='icon' sizes='16x16' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-32x32-c81451fd0d87890abd08b9db0a795d10339bb7c12662e9e9f3c15ac330bdaf9a.png' rel='icon' sizes='32x32' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-96x96-8df131d801eebf824632ce95b824704d0a928c3cf453c5222cbe555c87b1eb0f.png' rel='icon' sizes='96x96' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/favicon-194x194-728b6833bcd8ec9ff9fa15aba3595de5b9df51530f29547457c749719f1f0b8d.png' rel='icon' sizes='194x194' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/android-chrome-192x192-e7e88ca08f6e98bf706fceb62b57f86c338da64c83252bcc5a8b2f35fd89f191.png' rel='icon' sizes='192x192' type='image/png'>
<link href='https://cdn.rivals.com/production/assets/favicons/production-6bceccff7fae6f5e335858ba74b8e9ac335e7bf9d420edf1f92ecb7b9fdee02d.ico' rel='shortcut icon'>
<link href='https://cdn.rivals.com/production/assets/favicons/manifest-5ab6bada83e2c243aec32edcf5f419498d7897c6cfcca56ba6b1a16c7091f14d.json' rel='manifest'>
<script>
  var _sf_async_config = _sf_async_config || {};
  var subdomain = "ucf.rivals.com";
  /** CONFIGURATION START **/
  _sf_async_config.uid = 63621; // ACCOUNT NUMBER
  _sf_async_config.domain = subdomain;
  _sf_async_config.flickerControl = false;
  _sf_async_config.useCanonical = true;
  /** CONFIGURATION END **/
  var _sf_startpt = (new Date()).getTime();
</script>
<script async src='//static.chartbeat.com/js/chartbeat_mab.js'></script>

</head>
<body class='ucf contents-show_updated_layout' ng-app='rivals'>
<script>
  angular.module('rivals').run(function(googleAnalyticsService) {
    googleAnalyticsService.setGaClientId();
    })
</script>

<!--[if lte IE 9]><div class='browser-unsupported'>
<div class='browser-unsupported-text'>
You are using an
<strong>outdated</strong>
browser. Please
<a href='http://browsehappy.com/'>upgrade your browser</a>
to use Rivals.com
</div>
</div><![endif]-->

<style>
  @media screen and (max-width: 1023px) {
    .ucf #programming > h1 {
      background-color: #000000 !important; } }
  .ucf > header .notification-link .count-container {
    background-color: #000000 !important; }
  .ucf > header .wrapper-container {
    background-color: #000000 !important;
    display: block;
    position: fixed;
    top: 0px;
    width: 100%;
    z-index: 999; }
    @media screen and (min-width: 768px) {
      .ucf > header .wrapper-container {
        border-bottom: 5px solid #ba9a4c !important; } }
  .ucf > header .invalid-email-banner {
    background-color: #000000;
    height: 40px;
    line-height: 40px;
    position: relative;
    text-align: center;
    width: 100%;
    z-index: 998; }
    .ucf > header .invalid-email-banner a {
      color: #fff;
      vertical-align: middle; }
    .ucf > header .invalid-email-banner a:hover {
      color: #ba9a4c; }
  @media screen and (max-width: 767px) {
    .ucf > header .mobile-header {
      background-color: #ba9a4c !important;
      height: 5px;
      position: fixed;
      width: 100%;
      z-index: 50; } }
  .ucf > header hr {
    background-color: rgba(255, 255, 255, 0.55) !important; }
  .ucf > header .home {
    border-right: 1px solid rgba(255, 255, 255, 0.55) !important; }
  .ucf > header .second-nav {
    background-color: white !important; }
  @media screen and (max-width: 1023px) {
    .ucf > header .nav-row > ul,
    .ucf > header .third-nav {
      background-color: white !important; }
    .ucf > header .dropdown-toggle > i.fa {
      color: #000000 !important; } }
  .ucf > header .active {
    font-family: "Roboto", "Helvetica Neue", arial, sans-serif;
    font-weight: 500;
    color: #000000; }
  
  .site-primary-font-color {
    color: #000000; }
  
  .site-primary-background-color {
    background-color: #000000; }
  
  .site-secondary-font-color {
    color: #ba9a4c; }
  
  .site-secondary-background-color {
    background-color: #ba9a4c; }
  
  :root {
    --outbrain-primary-color: #000000;
    --outbrain-secondary-color: #ba9a4c; }
</style>

<header><nav ng-class='ctrl.currentUser ? "signed-in" : "signed-out"' ng-controller='NavController as ctrl' role='navigation'>
  <div class='wrapper-container'>
    <div class='wrapper logo-row'>
      <a alt="Rivals" href="//Rivals.rivals.com"><div class='rivals-logo-navbar-white'></div>
      </a>
      <a class='nav-menu-mobile' ng-click='ctrl.toggleContentNav($event)'></a>
      <a alt="UCF" class="school-header" href="//ucf.rivals.com"><img src="https://res-1.cloudinary.com/rivals/image/upload/a8qzpvecyxroueml2nzd" alt="A8qzpvecyxroueml2nzd" />
      </a>
      <div class='nav-right-controls'>
        <div class='subscribe-section' ng-cloak ng-if='ctrl.showSubscribe()'>
          <span>Join the Rivals community!</span>
          <a class='btn' ng-href='{{ ctrl.subscribePath }}'>Subscribe</a>
        </div>
        <rv-universal-search></rv-universal-search>
        <rv-user-dropdown current_user='ctrl.currentUser'></rv-user-dropdown>
        <rv-forums-info current_user='ctrl.currentUser' ng-if='ctrl.currentUser && (ctrl.isDesktop || ctrl.isTablet)'></rv-forums-info>
      </div>
    </div>
  </div>
  <div class='mobile-header'></div>
  <rv-header-alert class='alert-nav' scroll-min='40'></rv-header-alert>
  <hr>
  <div class='nav-row-container'>
    <div class='wrapper nav-row navbar-full' ng-cloak ng-if='!ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//ucf.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;ucf&#39;" limit="8"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='wrapper nav-row navbar-ellipsed' ng-cloak ng-if='ctrl.isTablet'>
      <ul>
        <li class="home top-nav"><a href="//ucf.rivals.com">Home</a></li>
        <rv-forum-navigation school-identifier="&#39;ucf&#39;" limit="4"></rv-forum-navigation>
        <li class="search top-nav"><a href="/search">Prospect Search</a></li>
        <rv-navigation navigation="ctrl.schoolByGroupDivision"></rv-navigation>
        <rv-user-menu-items current-user="ctrl.currentUser" ng-if="!ctrl.isTablet &amp;&amp; !ctrl.isDesktop" class="user-menu"></rv-user-menu-items>
      </ul>
    </div>
    <div class='nav-row invalid-email-banner' ng-cloak ng-if='ctrl.showEmailUpdateBanner'>
      <a ng-href='{{ctrl.userProfileEditPath}}'>
        Your account has an invalid email address. Please update it here.
      </a>
    </div>
  </div>
</nav>
</header>
<div class='alert-placeholder'>
<rv-header-alert></rv-header-alert>
</div>
<main class='wrapper'><script src="https://s.yimg.com/ss/rapid-3.24.js"></script>
<script>
  YAHOO.i13n.WEBWORKER_FILE = "js/rivals/analytics/rapidworker-1.2.js";
  
  var rapid = new YAHOO.i13n.Rapid({
    spaceid: 2022733158,
    ywa: {
      project_id: 10002066977754,
      document_group: 'content',
      member_id: 0
    },
    nol: 1,
    client_only: 1
  });
</script>

<script>
  var contentTitle = "Kyle Gibson embraces new staff"
</script>
<meta content='summary_large_image' name='twitter:card'>
<meta content='ucfsports' name='twitter:site'>
<meta content='Kyle Gibson embraces new staff' name='twitter:title'>
<meta content='Breaking up can be hard, but change is always a constant in college football.' name='twitter:description'>
<meta content='https://res-1.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_large/wd0tm5v6z1axsdaqdrbo' name='twitter:image'>
<div class='article-container-wrapper' ng-controller='ContentController' ng-init='init([{"id":1909165,"title":"Video: Spring Update with Randy Shannon","slug":"video-spring-update-with-randy-shannon","kind":"premium","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-29T19:41:00.393-05:00","summary":"With five practices under their belt, Randy Shannon likes the early progress they&#x0027;ve made.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/video-spring-update-with-randy-shannon","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1909156,"title":"Tyler Hudanick talks Heupel; building on National Championship season","slug":"tyler-hudanick-talks-heupel-building-on-national-championship-season","kind":"premium","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-29T19:00:30.735-05:00","summary":"The always-eloquent Tyler Hudanick spoke this week about several topics, including the transition to a new staff. ","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/tyler-hudanick-talks-heupel-building-on-national-championship-season","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1909144,"title":"UCF players put on a show at Pro Day","slug":"ucf-players-put-on-a-show-at-pro-day","kind":"free","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-29T18:09:56.717-05:00","summary":"Scouts from 31 NFL teams and representatives from several CFL franchises converged on UCF for their annual Pro Day.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/ucf-players-put-on-a-show-at-pro-day","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1908795,"title":"UCF Spring Football Photo Gallery","slug":"ucf-spring-football-photo-gallery-50","kind":"premium","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-28T20:09:45.033-05:00","summary":"Inside are more than 130 photos from UCF&#x0027;s fifth practice of spring. Pictured: Freshman LB Eriq Gilyard. ","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/ucf-spring-football-photo-gallery-50","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1908401,"title":"Get to know UCF OL coach Glen Elarbee","slug":"get-to-know-ucf-ol-coach-glen-elarbee","kind":"free","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-27T18:10:44.960-05:00","summary":"When Glen Elarbee was presented the opportunity to join Josh Heupel at UCF, the former Mizzou OL coach didn&#x0027;t hesitate.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/get-to-know-ucf-ol-coach-glen-elarbee","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1908294,"title":"McKenzie Milton: Heupel&#x0027;s energy level is &#x0027;infectious&#x0027;","slug":"mckenzie-milton-heupel-s-energy-level-is-infectious-","kind":"premium","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-27T13:07:05.586-05:00","summary":"How would McKenzie Milton describe his new coach?  Energetic.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/mckenzie-milton-heupel-s-energy-level-is-infectious-","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1908029,"title":"Spring Update with Coach Josh Heupel","slug":"spring-update-with-coach-josh-heupel","kind":"free","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-26T16:19:57.916-05:00","summary":"UCF is now getting into the flow of spring under Josh Heupel with four practices under their belt.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/spring-update-with-coach-josh-heupel","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1906887,"title":"Adrian Killins looks forward to another perfect season","slug":"adrian-killins-looks-forward-to-another-perfect-season","kind":"free","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-22T15:33:31.046-05:00","summary":"UCF in a lot of ways remains the talk of college football after reeling off an undefeated 13-0 season.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/adrian-killins-looks-forward-to-another-perfect-season","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1906876,"title":"Randy Shannon: &#x0027;Let&#x0027;s go to the next level&#x0027;","slug":"randy-shannon-let-s-go-the-next-level-","kind":"premium","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-22T14:48:52.493-05:00","summary":"Randy Shannon wants his players to focus on the future.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/randy-shannon-let-s-go-the-next-level-","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1906854,"title":"Tre Neal talks changes","slug":"tre-neal-talks-changes","kind":"premium","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-22T14:02:57.430-05:00","summary":"As one of UCF&#x0027;s seniors, safety Tre Neal has played for three coaches.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/tre-neal-talks-changes","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1906123,"title":"Brandon Moore wants UCF to be known for defense","slug":"brandon-moore-wants-ucf-to-be-known-for-defense","kind":"free","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-21T08:18:42.481-05:00","summary":"UCF&#x0027;s reputation has been built on offensive firepower, but Brandon Moore hopes defense starts to get their due. ","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/brandon-moore-wants-ucf-to-be-known-for-defense","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1906122,"title":"Milton had \"a lot of fun\" in first practice under Heupel ","slug":"milton-had-a-lot-of-fun-in-first-practice-under-heupel","kind":"premium","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-20T17:50:02.627-05:00","summary":"Some things have changed, but much remains the same.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/milton-had-a-lot-of-fun-in-first-practice-under-heupel","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1906087,"title":"UCF Spring Football Photo Gallery","slug":"ucf-spring-football-photo-gallery-49","kind":"free","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-20T16:36:51.553-05:00","summary":"More than 50 photos from the first day of spring practice. Pictured: Otis Anderson. ","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/ucf-spring-football-photo-gallery-49","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1906038,"title":"Video: Josh Heupel talks about opening spring practice","slug":"video-josh-heupel-talks-about-opening-spring-practice","kind":"free","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-20T13:56:48.520-05:00","summary":"It&#x0027;s a spring of new beginnings at UCF as Josh Heupel and a new staff look to keep building on the program&#x0027;s success. ","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/video-josh-heupel-talks-about-opening-spring-practice","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1906016,"title":"Video: Sights \u0026 Sounds from Day One","slug":"video-sights-sounds-from-day-one","kind":"premium","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-20T13:22:18.965-05:00","summary":"UCF hit the practice fields on Tuesday morning for the first spring practice under new head coach Josh Heupel. ","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/video-sights-sounds-from-day-one","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1905673,"title":"UCF, Louisville schedule home-and-home football series","slug":"ucf-louisville-schedule-home-and-home-football-series","kind":"free","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Article","live_at":"2018-03-19T12:39:06.126-05:00","summary":"UCF&#x0027;s future football schedules are slowly beginning to take shape.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/ucf-louisville-schedule-home-and-home-football-series","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1905469,"title":"Lovelady, Knights gearing up for FSU; beginning of league play","slug":"lovelady-knights-gearing-up-for-fsu-beginning-of-league-play","kind":"free","site_id":20,"sport":"baseball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-18T20:42:30.889-05:00","summary":"UCF&#x0027;s schedule is about to get a lot tougher with No. 6 FSU and No. 21 East Carolina on the horizon. ","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/lovelady-knights-gearing-up-for-fsu-beginning-of-league-play","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1904964,"title":"Maryland making a push for UCF QB commit Charlie Dean","slug":"maryland-making-a-push-for-ucf-qb-commit-charlie-dean","kind":"premium","site_id":20,"sport":"football","news_type":"recruiting","content_type":"Content::Link","live_at":"2018-03-16T21:59:06.374-05:00","summary":"After landing an offer, Charlie Dean visited Maryland on his spring break. ","deleted":false,"author_name":"Richie Schnyderite","author_title":"Terrapin Sports Report","permalink":"https://maryland.rivals.com/news/ucf-qb-commit-charlie-dean-talks-maryland-visit","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1904545,"title":"UCF Baseball enters final weekend before conference play","slug":"ucf-baseball-enters-final-weekend-before-conference-play","kind":"premium","site_id":20,"sport":"baseball","news_type":"team","content_type":"Content::Link","live_at":"2018-03-15T16:57:39.317-05:00","summary":"After this weekend&#x0027;s series vs. Chicago State, the focus will shift to UCF&#x0027;s conference slate. ","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.forums.rivals.com/threads/ucf-baseball-enters-final-weekend-before-conference-play.61419/","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1904544,"title":"Heupel reaches out to former football players","slug":"heupel-reaches-out-to-former-football-players","kind":"premium","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-15T16:55:23.490-05:00","summary":"UCF&#x0027;s new coach is putting out the welcome mat for lettermen. ","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.forums.rivals.com/threads/letter-from-josh-heupel-to-ucf-lettermen.61415/","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1903516,"title":"Recruit Rewind: Mike Hughes","slug":"recruit-rewind-mike-hughes-1","kind":"free","site_id":20,"sport":"football","news_type":"team","content_type":"Content::Link","live_at":"2018-03-13T10:30:00.000-05:00","summary":"Rivals analyst Adam Friedman looks back at Mike Hughes, the football recruit, now top NFL cornerback prospect. ","deleted":false,"author_name":"Adam Friedman","author_title":"Rivals.com Football Recruiting","permalink":"https://ucf.rivals.com/news/recruit-rewind-mike-hughes-ucf","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]},{"id":1903505,"title":"UCF&#x0027;s breakthrough must wait another year","slug":"ucf-s-breakthrough-must-wait-another-year","kind":"free","site_id":20,"sport":"basketball","news_type":"team","content_type":"Content::Article","live_at":"2018-03-12T21:16:12.588-05:00","summary":"This was supposed to be the breakout year for UCF Basketball.","deleted":false,"author_name":"Brandon Helwig","author_title":"Publisher","permalink":"https://ucf.rivals.com/news/ucf-s-breakthrough-must-wait-another-year","site_name":"UCFSports.com","type":"Content","programming":[],"associated_links":[]}], nil, 20, nil, true); subdomain = &#x0027;ucf&#x0027;; aolPlayerId = &#x0027;5964f78e9e45105cdae8d58d&#x0027;; aolCompanyId = &#x0027;595ea54b2a30cb7ee3e53963&#x0027;'>
<div class='horizontal-ad-container'>
<div id='boxLDRB'>
<div id='tgtLDRB'></div>
</div>
</div>
<div class='article-container new'>
<div class='left-side-modules-container siderail'>
<div class='left-modules-container'>
<div class='news-list homepage-module'>
<div class='section-header news-header' style='background: #000000'>
Ticker
</div>
<div class='news' ng-repeat='content in newsList()'>
<div class='article' ng-if='content.type === "Content"'>
<div class='forum-icon' ng-if='forumThread(content.content_type)'></div>
<a class='title' href='{{content.permalink}}' ng-class="{'indent': content.kind === 'premium'}">
<div ng-cloak>{{content.title}}</div>
</a>
<div class='byline'>
<div class='premium-icon' ng-if='content.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='link-icon' ng-if='link(content.content_type)'><?xml version="1.0" encoding="utf-8"?>
<!-- Generator: Adobe Illustrator 19.1.0, SVG Export Plug-In . SVG Version: 6.00 Build 0)  -->

<svg version="1.1" id="Layer_1" xmlns="http://www.w3.org/2000/svg" x="0px" y="0px" viewbox="0 0 16 12.2" enable-background="new 0 0 16 12.2" xml:space="preserve">
  <path id="XMLID_228_" fill="#0A4EA3" d="M9.1,8.8C8.3,10,7,10.7,5.5,10.7c-2.4,0-4.3-1.9-4.3-4.3s1.9-4.3,4.3-4.3
      c1.4,0,2.6,0.7,3.4,1.7h1.2C9.2,2.3,7.5,1.2,5.5,1.2c-2.9,0-5.3,2.4-5.3,5.3s2.4,5.3,5.3,5.3c2,0,3.8-1.2,4.7-2.9H9.1z"></path>
  <polygon id="XMLID_229_" fill="#0A4EA3" points="16.2,6.1 13.8,3.7 13.8,6.2 5.8,6.2 5.8,7.2 13.8,7.2 13.8,8.6 	"></polygon>
</svg>
</div>
<time datetime='{{content.live_at}}' ng-cloak>
{{timeAgo(content.live_at)}}
</time>
<a class='edit-article' href='/publishing/contents/{{content.id}}/edit' ng-show='$parent.isPublisher'>Edit</a>
</div>
</div>
<div class='tweet' ng-if='content.type === "Tweet"'>
<div class='tweet-icon'></div>
<a class='title' href='{{content.tweet_url}}' target='_blank'>
<div ng-bind-html='content.text_news_feed'></div>
</a>
</div>
</div>
</div>

<div class='side-rail-meta lrec-ad' ng-if="showLRECad('leftrail-below-ticker')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
<div class='side-rail-meta lrec-ad2'>
<div class='side-rail-box'>
<div id='boxLREC2'>
<div id='tgtLREC2'></div>
</div>
</div>
</div>

<rv-homepage-forums ad-referer='https://ucf.rivals.com/news/kyle-gibson-embraces-new-staff' background-color='#000000' base-api-url='https://ucf.forums.rivals.com/' homepage='false' message-board-url='ucf.forums.rivals.com' pub-ad='null' size='size' space-id='2022733158' subscribed-user='subscribedUser'></rv-homepage-forums>


<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>
</div>
</div>
<div class='article-display-wrapper'>
<div class='new-content'>
<div class='article-header'>
<div class='pull-right'>
<rv-share-links collapsed='true' print-url='https://ucf.rivals.com/news/kyle-gibson-embraces-new-staff/printable' site-name='UCFSports.com'></rv-share-links>
</div>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span class='article-header-age' ng-cloak>{{ timeAgo('2018-03-30 12:29:25 -0500') }}</span>
<span class='article-header-sport'>football</span>
<a class='edit-article updated-article-page' href='{{editPath(subdomain)}}//publishing/contents/1909188/edit' ng-cloak ng-show='isPublisher'>Edit</a>
</div>
<h2 class='article-title'>Kyle Gibson embraces new staff</h2>
<div class='header-image'></div>
<div class='author-byline'>
<div class='flex-container'>
<div class='vertical-align'>
<img class='circle-img' src='https://res-3.cloudinary.com/rivals/image/upload/f_auto,q_auto,t_author_bio/byj8qcrn30dckuhxibda'>
<span>
<span class='title-sm'>
Brandon Helwig
&bull;
</span>
<span class='type-sm'>UCFSports.com</span>
<div class='type-sm'>
<a href='//twitter.com/ucfsports' target='_blank'>@ucfsports</a>
</div>
</span>
</div>
<div class='vertical-align link-button' ng-click='authorBio()' ng-cloak>
<div class='caret-down' ng-cloak ng-show='!expandProfile'></div>
<div class='caret-up' ng-cloak ng-show='expandProfile'></div>
</div>
</div>
<div class='expanded-content' ng-cloak ng-if='expandProfile'>
<div class='flex-container'>
<span>
<span class='title-sm'>Publisher</span>
</span>
<script async charset='utf-8' src='//platform.twitter.com/widgets.js'></script>
<a class='twitter-follow-button' data-show-count='false' data-show-screen-name='false' data-size='large' href='//twitter.com/ucfsports'></a>
</div>
<div class='type-sm' ng-cloak ng-if='expandProfile'>

</div>
</div>
</div>
<div class='article-body-container'>
<div class='body-wrapper'>
<div class='article-body'><div class='upsell'>
<div class='upsell-content'>
<div class='row premium-divider'>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
<div class='premium-content col-sm-8 col-xs-12'>
<div class='premium-icon'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<span>Premium Content</span>
</div>
<div class='col-sm-8 col-xs-6'>
<hr>
</div>
</div>
<h3 class='upsell-headline'>Subscribe today to read the full article and get everything Rivals has to offer.</h3>
<div class='row buttons'>
<div class='col-xs-24 col-sm-12'>
<div class='subscribe'>
<a class="btn" href="/sign_up?preselected_site_id=20">Subscribe to Rivals</a>
</div>
</div>
<div class='sign-in col-xs-24 col-sm-12'>
<a class="btn" href="/users/sign_in">Sign in</a>
</div>
</div>
<div class='value-props row'>
<ul>
<li class='value-prop fa-before fa-check'>Member-only message boards</li>
<li class='value-prop fa-before fa-check'>Exclusive highlights and recruiting interviews</li>
<li class='value-prop fa-before fa-check'>Exclusive coverage of Rivals Camp Series</li>
<li class='value-prop fa-before fa-check'>Breaking recruiting news</li>
</ul>
</div>
</div>
<div class='video-ad-wrapper'>
<script async src='//c.jsrdn.com/s/cs.js?p=22546' type='text/javascript'></script>
<div class='video-container' id='ds_default_anchor'></div>
</div>

</div>
</div>
<div class='text-center'>
<rv-share-links print-url='https://ucf.rivals.com/news/kyle-gibson-embraces-new-staff/printable' site-name='UCFSports.com'></rv-share-links>
</div>
<div class='trending' ng-if='trendingArticles'>
<div class='article-subheader'>
trending
</div>
<div class='content' ng-cloak ng-repeat='article in trendingArticles'>
<a ng-href='/news/{{article.slug}}'>
<div class='title'>
{{ article.title }}
</div>
<div class='by-line'>
<div class='premium-icon' ng-if='article.kind === "premium"'><svg id="Layer_2" data-name="Layer 2" xmlns="http://www.w3.org/2000/svg" viewbox="0 0 14.54 12"><defs><style>.cls-1{fill:#777f85;}.cls-2{fill:#fff;}</style></defs><title>premium-icon</title>
<polygon class="cls-1" points="12.54 12 0 12 2 0 14.54 0 12.54 12"></polygon><path class="cls-2" d="M10.68,5.28H10.44A4.46,4.46,0,0,0,9,5.5a3.8,3.8,0,0,0-1.19.65,3.87,3.87,0,0,0-.53.51,2.64,2.64,0,0,0-.37.56,3.48,3.48,0,0,0-.2.53,4.28,4.28,0,0,0-.18.58L6.27,9.54H3.18l1.43-6H7.68L7.37,4.77a8,8,0,0,1,.8-0.88A4.6,4.6,0,0,1,9,3.32,3.8,3.8,0,0,1,9.85,3a4.6,4.6,0,0,1,1-.12h0.69l-0.49,2.4H10.71"></path></svg></div>
<div class='live-at'>
{{ timeAgo(article.live_at) }}
</div>
<div class='author'>
{{ article.author_name }}
</div>
</div>
</a>
</div>
</div>
</div>
<div class='spacer'></div>
</div>
</div>

</div>
<div class='enrichment-modules-container-updated siderail'>
<rv-enrichment-module ad-two='null' enrichments='[{"active":true,"type":"Commitment","football":true,"list_id":null,"list_title":null,"position":1},{"active":true,"type":"Schedule","football":true,"list_id":null,"list_title":null,"position":2},{"active":true,"type":"Twitter","football":null,"list_id":null,"list_title":null,"position":3}]' is-super-admin='' ncaab-schedule-year='2017' ncaaf-schedule-year='2018' new-article-layout='true' site='{"id":20,"legacy_id":908,"name":"UCFSports.com","friendly_name":"UCF","annual_discount":null,"subdomain":"ucf","primary_color":"000000","secondary_color":"ba9a4c","font_color":"ffffff","short_name":"ucf","maple_ncaaf_team_id":210,"maple_ncaaf_endpoint":"ncaaf/teams/ccf","maple_ncaab_team_id":103,"maple_ncaab_endpoint":"ncaab/teams/cap","maple_college_id":210,"google_analytics_id":"UA-81891349-1"}' twitter-feed='{"id":20,"site_id":20,"handle":"ucfsports","list_name":"ucfsports-com","created_at":"2016-02-01T12:24:45.054-06:00","updated_at":"2017-07-26T13:20:32.972-05:00","hashtags":[],"usernames":[],"max_number":null}'></rv-enrichment-module>
</div>
<div class='sticky-footer hidden'>
<div class='text-center'>
<rv-share-links collapsed='false' print-url='https://ucf.rivals.com/news/kyle-gibson-embraces-new-staff/printable' site-name='UCFSports.com'></rv-share-links>
</div>
</div>
</div>
<script>
  $(function () {
    if ('false' === 'true') {
      var comment = document.createComment("ads suppressed in development");
  
      document.body.appendChild(comment);
    }else{
      var ad_url = generateDarlaAdUrl('2022733158', 'https://ucf.rivals.com/news/kyle-gibson-embraces-new-staff');
  
      var script = document.createElement("script");
      script.src = ad_url;
  
      document.body.appendChild(script);
    }
  });
</script>

<script>
  var _sf_async_config = _sf_async_config || {};
  /** CONFIGURATION START **/
  var byline = document.querySelector('#byline');
  var onetimeAuthors = document.querySelector('#onetime-author');
  if (byline) { // Remove after completely transitioning to new layout (should definitely be done by Jan 1st 2018)
    var i = byline.innerText.indexOf('|');
    var author = byline.innerText.slice(0, i-1);
  } else if (onetimeAuthors) {
    // Possibly multiple authors
    var listAuthors = onetimeAuthors.innerText.split(/ ,| and/);
    var author = listAuthors.join(',');
  } else {
    var bylineNew = document.querySelector('.author-byline .title-sm');
    if (bylineNew) {
      var i = bylineNew.innerText.indexOf('•');
      var author = bylineNew.innerText.slice(0, i-1);
    }
  }
  function getAliasVariable() {
    var host = window.location.host.split('.');
    // add 'n' if it is a Site page
    if (_.include(['n', 'acceptance', 'local'], host[0].toLowerCase()) || host.length == 4) {
      if (_.include(['n'], host[0].toLowerCase())) { host.shift() } // If we are on nationals prod, drop the n subdomain from the alias (aka make it be just rivals.com)
      return host.join('.') + window.location.pathname
    } else {
      host.splice(1, 0, 'n');
      return host.join('.') + window.location.pathname
    }
  }
  _sf_async_config.section = 'article';
  _sf_async_config.authors = (byline || bylineNew || onetimeAuthors) ? author : '';
  _sf_async_config.alias = getAliasVariable();
  _sf_async_config.title = "Kyle Gibson embraces new staff";
  _sf_async_config.sections = 'content,content-football,content-football-premium,content-article';
  /** CONFIGURATION END **/
  function loadChartbeat() {
    window._sf_endpt = (new Date()).getTime();
    var e = document.createElement('script');
    e.setAttribute('language', 'javascript');
    e.setAttribute('type', 'text/javascript');
    e.setAttribute('src', '//static.chartbeat.com/js/chartbeat_video.js');
    document.body.appendChild(e);
  };
</script>

<div class='article-ads-footer'>
<div class='lrec-ads'>
<div class='side-rail-meta lrec-ad' ng-if="showLRECad('footer')">
<div class='side-rail-box'>
<div id='boxLREC'>
<div id='tgtLREC'></div>
</div>
</div>
</div>
</div>
<div class='OUTBRAIN' data-ob-template='Rivals.com' data-src='https://ucf.rivals.com' data-widget-id='AR_4'></div>
<script src='https://widgets.outbrain.com/outbrain.js' type='text/javascript'></script>
</div>

</div>
</main>
<footer>
<ul class='footer-links list-inline'>
<li>
<a href='https://n.rivals.com/news/about-us'>About</a>
<a href='https://policies.yahoo.com/us/en/yahoo/privacy/products/rivals/'>Privacy Policy</a>
<a href='https://policies.yahoo.com/us/en/yahoo/ip/index.htm'>Copyright/IP Policy</a>
<a href='https://n.rivals.com/news/contact-us-5'>Contact Us</a>
<a href='/tos'>Terms of Service</a>
<a href='https://n.rivals.com/news/member-services'>Member Services</a>
</li>
</ul>
<div class='copyright-notice'>&copy; Yahoo! Inc.</div>
</footer>
</body>
<!-- Begin comScore Tag -->

<script>
  var _comscore = _comscore || [];
  _comscore.push({
    c1: "2",
    c2: "7241469",
    c5: "2022733158",
    c7: "https://ucf.rivals.com/news/kyle-gibson-embraces-new-staff"
  });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://s.yimg.com/lq" : "http://l.yimg.com/d") + "/lib/3pm/cs_0.2.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>

<noscript>
  <img src="https://sb.scorecardresearch.com/p?c1=2&c2=7241469&c7=https%3A%2F%2Fucf.rivals.com%2Fnews%2Fkyle-gibson-embraces-new-staff&c5=2022733158&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

</html>
